CrashPlan Cloud Authentication Issue
Incident Report for CrashPlan Group LLC
Resolved
This incident has been resolved.
Posted May 31, 2023 - 08:54 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 25, 2023 - 13:59 CDT
Investigating
We have detected an issue with CrashPlan’s authority servers, and are investigating the issue.
Posted May 25, 2023 - 12:49 CDT
This incident affected: CrashPlan (console.us1.crashplan.com).