CrashPlan Web Restore Issues
Incident Report for CrashPlan Group LLC
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 11:25 CDT
Update
We are continuing to investigate this issue.
Posted Oct 10, 2024 - 11:24 CDT
Investigating
We are aware of an issue that may impact a small amount of users attempting to perform web restores. Our team is actively working on identifying the root cause of the issue and working on a fix.
Posted Oct 08, 2024 - 11:14 CDT
This incident affected: CrashPlan (console.us2.crashplanpro.com (Small Business)).