CrashPlan.com Website Intermittent Issues

Incident Report for CrashPlan Group LLC

Resolved

This incident has been resolved.
Posted Feb 25, 2023 - 11:57 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2023 - 20:55 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 24, 2023 - 16:46 CST

Investigating

We are aware of ongoing intermittent connectivity issues with our crashplan.com website and are working with our vendor to resolve them. We will post further periodic updates here. These issues do not affect the CrashPlan product itself.
Posted Feb 24, 2023 - 16:22 CST
This incident affected: Support services.