CrashPlan Cloud Console is Down

Incident Report for CrashPlan Group LLC

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 17:12 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2025 - 15:58 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 23, 2025 - 14:51 CDT

Investigating

We have detected an issue with CrashPlan’s authority servers, and are investigating the issue.
Posted Apr 23, 2025 - 14:25 CDT
This incident affected: CrashPlan (console.us1.crashplan.com, console.us2.crashplan.com, console.us2.crashplanpro.com (Small Business)) and Subscription services.