Verification is currently underway for the maintenance items.
Posted Mar 12, 2025 - 20:30 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2025 - 20:00 CDT
Scheduled
System maintenance with potential to cause our website an interruption greater than 15 minutes is scheduled for this Wednesday from 8:00 p.m. to 10:00 p.m. US Central Time (CT). Customers and potential customers may experience limited functionality when accessing our website including attempting to sign-up for free trials during this maintenance. CrashPlan application admin, backup, restore, and Support site functionality are not affected by this maintenance.
Posted Mar 10, 2025 - 16:38 CDT
This scheduled maintenance affected: Subscription services.